NuoDB Client-only Package Drivers

The NuoDB Client-only package contains the following supported client interfaces:

Driver Support Tier Supported Language(s) Platforms Supported Version(s) Supported NuoDB Interface

JDBC

1

Java

All

Java 8 and 11

Native Protocol

NuoClient

1

C

All

GCC, clang, MSVC15

Native Protocol

NuoRemote

1

C++

All

GCC, clang, MSVC15

NuoClient

ODBC

1

N/A

Windows 64-bit

MSVC15

C++ NuoRemote API

UnixODBC

1

N/A

Linux

Version 2.3.x of the unixODBC library. The NuoDB unixODBC driver does not support earlier versions.

C++ NuoRemote API

Python

1

Python 2 / Python 3

Native Python driver

https://github.com/nuodb/nuodb-python

Native Protocol

Python 2.7 must be installed in order to use the NuoDB Admin nuocmd command and the pynuoadmin Python module provided by the client package.

To download, visit the NuoDB Client-only Package repository on the NuoDB Github site.